Which browsers are compatible with WooCommerce POS?

The following browsers have been tested using Browserstack:

  • Chrome 31+
  • Firefox 31+
  • Safari 8+
  • Opera 28+
  • iOS Safari 8+
  • Android Browser 4.4+
  • Microsoft Edge
compatibility-chart
Figure: Browsers compatible with WooCommerce POS

IndexedDB

WooCommerce POS uses IndexedDB to persist the product database on your computer or device. IndexedDB is currently a 'Candidate Recommendation' specification by the W3C and is not implemented by all browsers. To see if your browser is compatible please check caniuse.com.

WooCommerce POS also uses the Flexbox Layout module, currently a W3C Last Call Working Draft. To see if your browser is compatible please check caniuse.com.

Private Browsing

Some browsers will disable access to IndexedDB when Private Browsing is enabled. This will result in an IndexedDB Error shown below.

IndexedDB Error
Figure: Example of indexedDB error due to Private Browsing

Adding a webpage to your Home Screen in iOS will force it to open in a Private session. If you add the POS to your Home Screen in iOS you will get the error message above.